import re
regex = re.compile(r"https:\/\/[a-z\.]+.kaspersky-labs\.com\/[0-9A-Z\-]+\/main\.js")
test_str = "https://gc.kis.scr.kaspersky-labs.com/3AB9A552-5B01-8648-A873-82DD69063EB6/main.js"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")