import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/[a-z\\.]+.kaspersky-labs\\.com\\/[0-9A-Z\\-]+\\/main\\.js";
final String string = "https://gc.kis.scr.kaspersky-labs.com/3AB9A552-5B01-8648-A873-82DD69063EB6/main.js";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}