using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,3}([ ,]?\d{3})*([.,]\d+)?$";
string input = @"valid
1000
1,000
1,000.00
1000.00
1,000,000.12
invalid
1000.00.00
1,0.00
1,000,00.00
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}