import re
regex = re.compile(r"^\d{1,3}([ ,]?\d{3})*([.,]\d+)?$", flags=re.MULTILINE)
test_str = ("valid\n"
"1000\n"
"1,000\n"
"1,000.00\n"
"1000.00\n"
"1,000,000.12\n\n"
"invalid\n"
"1000.00.00\n"
"1,0.00\n"
"1,000,00.00\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")