re = /^\d{1,3}([ ,]?\d{3})*([.,]\d+)?$/m
str = 'valid
1000
1,000
1,000.00
1000.00
1,000,000.12
invalid
1000.00.00
1,0.00
1,000,00.00
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end