using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\?php\s(?:(?!<\?php\s|\$info).)*?\$info.*?\?>";
string input = @"bla bla <?php echo(""hello world"") ?> <?php
echo($info[""xx""])
?> bla and bla
bla bla <?php
echo($info[""yy""])
?> bla bla and bla";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}