re = /<\?php\s(?:(?!<\?php\s|\$info).)*?\$info.*?\?>/m
str = 'bla bla <?php echo("hello world") ?> <?php
echo($info["xx"])
?> bla and bla
bla bla <?php
echo($info["yy"])
?> bla bla and bla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end