use strict;
my $str = 'bla bla <?php echo("hello world") ?> <?php
echo($info["xx"])
?> bla and bla
bla bla <?php
echo($info["yy"])
?> bla bla and bla';
my $regex = qr/<\?php\s(?:(?!<\?php\s|\$info).)*?\$info.*?\?>/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}