const regex = /<\?php\s(?:(?!<\?php\s|\$info).)*?\$info.*?\?>/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\?php\\s(?:(?!<\\?php\\s|\\$info).)*?\\$info.*?\\?>', 'gms')
const str = `bla bla <?php echo("hello world") ?> <?php
echo(\$info["xx"])
?> bla and bla
bla bla <?php
echo(\$info["yy"])
?> bla bla and bla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}