$re = '/<\?php\s(?:(?!<\?php\s|\$info).)*?\$info.*?\?>/ms';
$str = 'bla bla <?php echo("hello world") ?> <?php
echo($info["xx"])
?> bla and bla
bla bla <?php
echo($info["yy"])
?> bla bla and bla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);