using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ng-repeat=""([a-zA-Z]*)\s+(in)\s+([a-zA-Z\.{1}().]*)\s+track by \$index""";
string input = @"ng-repeat=""research in researches.main track by $index""
ng-repeat=""research in researches track by $index""
ng-repeat=""patient in patientGroup.getPatients() track by $index""
ng-repeat=""survey in model.getResearches().sub track by $index""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}