import Foundation
let pattern = #"ng-repeat="([a-zA-Z]*)\s+(in)\s+([a-zA-Z\.{1}().]*)\s+track by \$index""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ng-repeat="research in researches.main track by $index"
ng-repeat="research in researches track by $index"
ng-repeat="patient in patientGroup.getPatients() track by $index"
ng-repeat="survey in model.getResearches().sub track by $index"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)