// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"ng-repeat="([a-zA-Z]*)\s+(in)\s+([a-zA-Z\.{1}().]*)\s+track by \$index""#).unwrap();
let string = "ng-repeat=\"research in researches.main track by $index\"
ng-repeat=\"research in researches track by $index\"
ng-repeat=\"patient in patientGroup.getPatients() track by $index\"
ng-repeat=\"survey in model.getResearches().sub track by $index\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}