import re
regex = re.compile(r"ng-repeat=\"([a-zA-Z]*)\s+(in)\s+([a-zA-Z\.{1}().]*)\s+track by \$index\"")
test_str = ("ng-repeat=\"research in researches.main track by $index\"\n\n"
"ng-repeat=\"research in researches track by $index\"\n\n"
"ng-repeat=\"patient in patientGroup.getPatients() track by $index\"\n\n"
"ng-repeat=\"survey in model.getResearches().sub track by $index\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")