use strict;
my $str = 'Android OS 5.1 / API (LYZ28N/500200305)
Android OS 5.1.1 / API (LYZ28N/500200305)
Android OS 10 / API-29 (LYZ28N/500200305)
Android OS 102222.1323121312 / API-29 (LYZ28N/500200305)
iPhone OS 5.12 / API (LYZ28N/500200305)
iPhone OS 5 / API (LYZ28N/500200305)
iPhone OS 5.1.10000.1.1.1.1.1.1.1.1 / API (LYZ28N/500200305)';
my $regex = qr/^(?<Name>\w+)\s\w+\s(?<Major>\*|\d+)\.?(?<Minor>\*|\d+)?\.?(?<Patch>\*|\d+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}