import Foundation
let pattern = #"^(?<Name>\w+)\s\w+\s(?<Major>\*|\d+)\.?(?<Minor>\*|\d+)?\.?(?<Patch>\*|\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Android OS 5.1 / API (LYZ28N/500200305)
Android OS 5.1.1 / API (LYZ28N/500200305)
Android OS 10 / API-29 (LYZ28N/500200305)
Android OS 102222.1323121312 / API-29 (LYZ28N/500200305)
iPhone OS 5.12 / API (LYZ28N/500200305)
iPhone OS 5 / API (LYZ28N/500200305)
iPhone OS 5.1.10000.1.1.1.1.1.1.1.1 / API (LYZ28N/500200305)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)