re = /^(?<Name>\w+)\s\w+\s(?<Major>\*|\d+)\.?(?<Minor>\*|\d+)?\.?(?<Patch>\*|\d+)?/m
str = 'Android OS 5.1 / API (LYZ28N/500200305)
Android OS 5.1.1 / API (LYZ28N/500200305)
Android OS 10 / API-29 (LYZ28N/500200305)
Android OS 102222.1323121312 / API-29 (LYZ28N/500200305)
iPhone OS 5.12 / API (LYZ28N/500200305)
iPhone OS 5 / API (LYZ28N/500200305)
iPhone OS 5.1.10000.1.1.1.1.1.1.1.1 / API (LYZ28N/500200305)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end