#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?!Zns?\b)[a-zA-Z]+\.\s"
Local $sString = "1) aaa. Zn. bbb " & @CRLF & _
"2) aaa. Zn. bbb. " & @CRLF & _
"3) aaa Zn. bbb. =" & @CRLF & _
"4) aaa Zn. bbb " & @CRLF & _
"5) aaa Bns. bbb " & @CRLF & _
"6) aaa Bns. Bbb " & @CRLF & _
"7) aaa Zn. Aaa Bns. Bbb " & @CRLF & _
"8) 1 " & @CRLF & _
"9) aaa " & @CRLF & _
"10) aaa. " & @CRLF & _
"11) aaa Abbb " & @CRLF & _
"12) aaa. Zns. bbb " & @CRLF & _
"13) aaa. Zns. bbb. " & @CRLF & _
"14) aaa Zns. bbb. " & @CRLF & _
"15) aaa Zns. bbb "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")