const regex = /\b(?!Zns?\b)[a-zA-Z]+\.\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!Zns?\\b)[a-zA-Z]+\\.\\s', 'gm')
const str = `1) aaa. Zn. bbb
2) aaa. Zn. bbb.
3) aaa Zn. bbb. =
4) aaa Zn. bbb
5) aaa Bns. bbb
6) aaa Bns. Bbb
7) aaa Zn. Aaa Bns. Bbb
8) 1
9) aaa
10) aaa.
11) aaa Abbb
12) aaa. Zns. bbb
13) aaa. Zns. bbb.
14) aaa Zns. bbb.
15) aaa Zns. bbb `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}