import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!Zns?\\b)[a-zA-Z]+\\.\\s";
final String string = "1) aaa. Zn. bbb \n"
+ "2) aaa. Zn. bbb. \n"
+ "3) aaa Zn. bbb. =\n"
+ "4) aaa Zn. bbb \n"
+ "5) aaa Bns. bbb \n"
+ "6) aaa Bns. Bbb \n"
+ "7) aaa Zn. Aaa Bns. Bbb \n"
+ "8) 1 \n"
+ "9) aaa \n"
+ "10) aaa. \n"
+ "11) aaa Abbb \n"
+ "12) aaa. Zns. bbb \n"
+ "13) aaa. Zns. bbb. \n"
+ "14) aaa Zns. bbb. \n"
+ "15) aaa Zns. bbb ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}