$re = '/\b(?!Zns?\b)[a-zA-Z]+\.\s/m';
$str = '1) aaa. Zn. bbb
2) aaa. Zn. bbb.
3) aaa Zn. bbb. =
4) aaa Zn. bbb
5) aaa Bns. bbb
6) aaa Bns. Bbb
7) aaa Zn. Aaa Bns. Bbb
8) 1
9) aaa
10) aaa.
11) aaa Abbb
12) aaa. Zns. bbb
13) aaa. Zns. bbb.
14) aaa Zns. bbb.
15) aaa Zns. bbb ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);