#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z0-9]+(_[a-z0-9]+){2,}(\|[a-z0-9]+(_[a-z0-9]+){2,})*$"
Local $sString = "xyz3_ffff_uyh6|hgyt6_jihhhh5_y" & @CRLF & _
"uuu_hhhhh_rhfhfh_hhhg" & @CRLF & _
"uuuuu_ooi8_gfrgg|fhdjsh_hhgy_6y6_bhhhh|ddd6_gggg_uuuu7" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")