using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]+(_[a-z0-9]+){2,}(\|[a-z0-9]+(_[a-z0-9]+){2,})*$";
string input = @"xyz3_ffff_uyh6|hgyt6_jihhhh5_y
uuu_hhhhh_rhfhfh_hhhg
uuuuu_ooi8_gfrgg|fhdjsh_hhgy_6y6_bhhhh|ddd6_gggg_uuuu7
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}