use strict;
my $str = 'xyz3_ffff_uyh6|hgyt6_jihhhh5_y
uuu_hhhhh_rhfhfh_hhhg
uuuuu_ooi8_gfrgg|fhdjsh_hhgy_6y6_bhhhh|ddd6_gggg_uuuu7
';
my $regex = qr/^[a-z0-9]+(_[a-z0-9]+){2,}(\|[a-z0-9]+(_[a-z0-9]+){2,})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}