import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]+(_[a-z0-9]+){2,}(\\|[a-z0-9]+(_[a-z0-9]+){2,})*$";
final String string = "xyz3_ffff_uyh6|hgyt6_jihhhh5_y\n"
+ "uuu_hhhhh_rhfhfh_hhhg\n"
+ "uuuuu_ooi8_gfrgg|fhdjsh_hhgy_6y6_bhhhh|ddd6_gggg_uuuu7\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}