$re = '/^[a-z0-9]+(_[a-z0-9]+){2,}(\|[a-z0-9]+(_[a-z0-9]+){2,})*$/m';
$str = 'xyz3_ffff_uyh6|hgyt6_jihhhh5_y
uuu_hhhhh_rhfhfh_hhhg
uuuuu_ooi8_gfrgg|fhdjsh_hhgy_6y6_bhhhh|ddd6_gggg_uuuu7
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);