$re = '/^(?<ALL>[^H\n\r]*(?:(?<ID>H-\d{4}).*|.[^H\n\r]*)*)/m';
$str = 'Sample line with H-5722 id
Sample line without id
Sample line without id H.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);