re = /^(?<ALL>[^H\n\r]*(?:(?<ID>H-\d{4}).*|.[^H\n\r]*)*)/m
str = 'Sample line with H-5722 id
Sample line without id
Sample line without id H.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end