#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)srcset="[^"]+?""
Local $sString = "lorem ipsum srcset="" & @CRLF & _
" wp-content/uploads/2018/06/labirint.jpg 907w," & @CRLF & _
" wp-content/uploads/2018/06/labirint-150x150.jpg 150w," & @CRLF & _
" wp-content/uploads/2018/06/labirint-300x300.jpg 300w," & @CRLF & _
" wp-content/uploads/2018/06/labirint-768x768.jpg 768w," & @CRLF & _
" wp-content/uploads/2018/06/labirint-350x350.jpg 350w," & @CRLF & _
" wp-content/uploads/2018/06/labirint-600x600.jpg 600w" & @CRLF & _
" " dolor si amet"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")