// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)srcset="[^"]+?""#).unwrap();
let string = "lorem ipsum srcset=\"
wp-content/uploads/2018/06/labirint.jpg 907w,
wp-content/uploads/2018/06/labirint-150x150.jpg 150w,
wp-content/uploads/2018/06/labirint-300x300.jpg 300w,
wp-content/uploads/2018/06/labirint-768x768.jpg 768w,
wp-content/uploads/2018/06/labirint-350x350.jpg 350w,
wp-content/uploads/2018/06/labirint-600x600.jpg 600w
\" dolor si amet";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}