use strict;
my $str = 'lorem ipsum srcset="
wp-content/uploads/2018/06/labirint.jpg 907w,
wp-content/uploads/2018/06/labirint-150x150.jpg 150w,
wp-content/uploads/2018/06/labirint-300x300.jpg 300w,
wp-content/uploads/2018/06/labirint-768x768.jpg 768w,
wp-content/uploads/2018/06/labirint-350x350.jpg 350w,
wp-content/uploads/2018/06/labirint-600x600.jpg 600w
" dolor si amet';
my $regex = qr/srcset="[^"]+?"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}