import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "srcset=\"[^\"]+?\"";
final String string = "lorem ipsum srcset=\"\n"
+ " wp-content/uploads/2018/06/labirint.jpg 907w,\n"
+ " wp-content/uploads/2018/06/labirint-150x150.jpg 150w,\n"
+ " wp-content/uploads/2018/06/labirint-300x300.jpg 300w,\n"
+ " wp-content/uploads/2018/06/labirint-768x768.jpg 768w,\n"
+ " wp-content/uploads/2018/06/labirint-350x350.jpg 350w,\n"
+ " wp-content/uploads/2018/06/labirint-600x600.jpg 600w\n"
+ " \" dolor si amet";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}