$re = '/srcset="[^"]+?"/m';
$str = 'lorem ipsum srcset="
wp-content/uploads/2018/06/labirint.jpg 907w,
wp-content/uploads/2018/06/labirint-150x150.jpg 150w,
wp-content/uploads/2018/06/labirint-300x300.jpg 300w,
wp-content/uploads/2018/06/labirint-768x768.jpg 768w,
wp-content/uploads/2018/06/labirint-350x350.jpg 350w,
wp-content/uploads/2018/06/labirint-600x600.jpg 600w
" dolor si amet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);