package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/(?:w{3}\.)?example\.com\/[A-Z]+(\/[a-z0-9]+)?\/?$`)
var str = `http://example.com/ASDFG/page1/
http://example.com/ASDFG/page1
http://example.com/ASDFG
http://example.com/ASDFG/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}