import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/(?:w{3}\\.)?example\\.com\\/[A-Z]+(\\/[a-z0-9]+)?\\/?$";
final String string = "http://example.com/ASDFG/page1/\n"
+ "http://example.com/ASDFG/page1\n"
+ "http://example.com/ASDFG\n"
+ "http://example.com/ASDFG/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}