re = /^https?:\/\/(?:w{3}\.)?example\.com\/[A-Z]+(\/[a-z0-9]+)?\/?$/m
str = 'http://example.com/ASDFG/page1/
http://example.com/ASDFG/page1
http://example.com/ASDFG
http://example.com/ASDFG/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end