$re = '/^https?:\/\/(?:w{3}\.)?example\.com\/[A-Z]+(\/[a-z0-9]+)?\/?$/m';
$str = 'http://example.com/ASDFG/page1/
http://example.com/ASDFG/page1
http://example.com/ASDFG
http://example.com/ASDFG/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);