// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https?:\/\/(?:w{3}\.)?example\.com\/[A-Z]+(\/[a-z0-9]+)?\/?$").unwrap();
let string = "http://example.com/ASDFG/page1/
http://example.com/ASDFG/page1
http://example.com/ASDFG
http://example.com/ASDFG/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}