using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^users/(?P<pk>\d+)(?:/(?P<username>[-\w]+))?(?:/(?P<tab>[-\w]+))?/?";
string input = @"users/24
users/24/
users/24/sam
users/24/sam/
users/24/sam/tab_name
users/24/sam/tab_name/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}