import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^users/(?P<pk>\\d+)(?:/(?P<username>[-\\w]+))?(?:/(?P<tab>[-\\w]+))?/?";
final String string = "users/24\n"
+ "users/24/\n"
+ "users/24/sam\n"
+ "users/24/sam/\n"
+ "users/24/sam/tab_name\n"
+ "users/24/sam/tab_name/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}