import re
regex = re.compile(r"^users/(?P<pk>\d+)(?:/(?P<username>[-\w]+))?(?:/(?P<tab>[-\w]+))?/?", flags=re.MULTILINE)
test_str = ("users/24\n"
"users/24/\n"
"users/24/sam\n"
"users/24/sam/\n"
"users/24/sam/tab_name\n"
"users/24/sam/tab_name/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")