import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z_]\\d*):(?!\\d)|:([A-Za-z_])";
final String string = "2018-05-21T00:00:00+02:00\n"
+ "00:00:00\n"
+ "00:00\n"
+ ":light at 07:15:0000\n\n"
+ ":occurence1\n"
+ ":occurence2\n\n"
+ "light: at 07:15:0000\n\n"
+ "occurence1:\n"
+ "occurence2:\n"
+ "occurence10:\n"
+ "occurence20:";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}