import Foundation
let pattern = #"([A-Za-z_]\d*):(?!\d)|:([A-Za-z_])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2018-05-21T00:00:00+02:00
00:00:00
00:00
:light at 07:15:0000
:occurence1
:occurence2
light: at 07:15:0000
occurence1:
occurence2:
occurence10:
occurence20:
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)