import re
regex = re.compile(r"([A-Za-z_]\d*):(?!\d)|:([A-Za-z_])", flags=re.MULTILINE)
test_str = ("2018-05-21T00:00:00+02:00\n"
"00:00:00\n"
"00:00\n"
":light at 07:15:0000\n\n"
":occurence1\n"
":occurence2\n\n"
"light: at 07:15:0000\n\n"
"occurence1:\n"
"occurence2:\n"
"occurence10:\n"
"occurence20:")
subst = "\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)