$re = '/([A-Za-z_]\d*):(?!\d)|:([A-Za-z_])/m';
$str = '2018-05-21T00:00:00+02:00
00:00:00
00:00
:light at 07:15:0000
:occurence1
:occurence2
light: at 07:15:0000
occurence1:
occurence2:
occurence10:
occurence20:';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;