use strict;
my $str = '2018-05-21T00:00:00+02:00
00:00:00
00:00
:light at 07:15:0000
:occurence1
:occurence2
light: at 07:15:0000
occurence1:
occurence2:
occurence10:
occurence20:';
my $regex = qr/([A-Za-z_]\d*):(?!\d)|:([A-Za-z_])/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";