import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Za-z0-9]\\s?)+\\s-\\s(Before|After)\\s((Insert|Update|Delete)|(Insert\\/Update))\\s-\\s([A-Za-z0-9]\\s?)+$";
final String string = "Valid Cases matching standards:\n\n"
+ "Opportunity - Before Insert/Update - Update Amount Before We Die\n"
+ "Case - After Update - Send Notification\n"
+ "Lead - Before Delete - Archive Record\n"
+ "Opportunity Line Item - After Insert - 123 sdsad asdasd\n"
+ "Quote Line Asset - Before Insert - Hello World \n"
+ "Account - After Update - Yes Man This Can Be Anything\n\n\n"
+ "Invalid cases:\n"
+ "account - Before Save - Update Name (Object should start with an uppercase letter)\n"
+ "Account - before save - Update Name (Context should start with an uppercase letter)\n"
+ "Account - Before Save - update name (Action should start with an uppercase letter)\n"
+ "Account-Before Save-Update Name (Missing spaces around hyphens)\n"
+ "Account - Before/After Save - Update Name (Invalid characters in Context)\n"
+ "Custom_Object__c - After Undelete - Restore Record\n"
+ "Opportunity_Line_Item - Before Insert - Validate Quantity";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}