# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([A-Za-z0-9]\s?)+\s-\s(Before|After)\s((Insert|Update|Delete)|(Insert\/Update))\s-\s([A-Za-z0-9]\s?)+$"
test_str = ("Valid Cases matching standards:\n\n"
"Opportunity - Before Insert/Update - Update Amount Before We Die\n"
"Case - After Update - Send Notification\n"
"Lead - Before Delete - Archive Record\n"
"Opportunity Line Item - After Insert - 123 sdsad asdasd\n"
"Quote Line Asset - Before Insert - Hello World \n"
"Account - After Update - Yes Man This Can Be Anything\n\n\n"
"Invalid cases:\n"
"account - Before Save - Update Name (Object should start with an uppercase letter)\n"
"Account - before save - Update Name (Context should start with an uppercase letter)\n"
"Account - Before Save - update name (Action should start with an uppercase letter)\n"
"Account-Before Save-Update Name (Missing spaces around hyphens)\n"
"Account - Before/After Save - Update Name (Invalid characters in Context)\n"
"Custom_Object__c - After Undelete - Restore Record\n"
"Opportunity_Line_Item - Before Insert - Validate Quantity")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.