const regex = /^([A-Za-z0-9]\s?)+\s-\s(Before|After)\s((Insert|Update|Delete)|(Insert\/Update))\s-\s([A-Za-z0-9]\s?)+$/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Za-z0-9]\\s?)+\\s-\\s(Before|After)\\s((Insert|Update|Delete)|(Insert\\\/Update))\\s-\\s([A-Za-z0-9]\\s?)+$', 'img')
const str = `Valid Cases matching standards:
Opportunity - Before Insert/Update - Update Amount Before We Die
Case - After Update - Send Notification
Lead - Before Delete - Archive Record
Opportunity Line Item - After Insert - 123 sdsad asdasd
Quote Line Asset - Before Insert - Hello World
Account - After Update - Yes Man This Can Be Anything
Invalid cases:
account - Before Save - Update Name (Object should start with an uppercase letter)
Account - before save - Update Name (Context should start with an uppercase letter)
Account - Before Save - update name (Action should start with an uppercase letter)
Account-Before Save-Update Name (Missing spaces around hyphens)
Account - Before/After Save - Update Name (Invalid characters in Context)
Custom_Object__c - After Undelete - Restore Record
Opportunity_Line_Item - Before Insert - Validate Quantity`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}