$re = '/^([A-Za-z0-9]\s?)+\s-\s(Before|After)\s((Insert|Update|Delete)|(Insert\/Update))\s-\s([A-Za-z0-9]\s?)+$/im';
$str = 'Valid Cases matching standards:
Opportunity - Before Insert/Update - Update Amount Before We Die
Case - After Update - Send Notification
Lead - Before Delete - Archive Record
Opportunity Line Item - After Insert - 123 sdsad asdasd
Quote Line Asset - Before Insert - Hello World
Account - After Update - Yes Man This Can Be Anything
Invalid cases:
account - Before Save - Update Name (Object should start with an uppercase letter)
Account - before save - Update Name (Context should start with an uppercase letter)
Account - Before Save - update name (Action should start with an uppercase letter)
Account-Before Save-Update Name (Missing spaces around hyphens)
Account - Before/After Save - Update Name (Invalid characters in Context)
Custom_Object__c - After Undelete - Restore Record
Opportunity_Line_Item - Before Insert - Validate Quantity';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);